Page Index Toggle Pages: 1 Send Topic | Print
Normal Topic HandySaw DS playback in Manual Trimmer (Read 3299 times)
Davis
Forum Administrator
*****
Offline


Admin

Posts: 65
Location: Ukraine
Joined: 08.11.2005
Gender: Male
Re: HandySaw DS playback in Manual Trimmer
Reply #6 - 01.03.2011 at 10:56:12
Print Post  
Angelica Vire,
Does this version work for you?
P.S. Seems like this is bot.
« Last Edit: 02.03.2011 at 10:06:12 by Davis »  

Dmitry Sinitsyn,
Davis Software
Back to top
WWW  
IP Logged
 
Hyomil
New Member
*
Offline


I Love YaBB 2!

Posts: 3
Joined: 22.01.2011
Re: HandySaw DS playback in Manual Trimmer
Reply #5 - 24.02.2011 at 03:12:00
Print Post  
Here's the link to the latest beta where its fixed for me (using the Media Player Classic filters described in the manual; I haven't tested any others)

http://www.davisr.com/downloads/temp/InstallHandySawDS.4.4.189.rar

Note that you must use DVDPatcher (I think set to patch the whole file, but I didn't test just patching the first part) to patch the header of the NTSC MPEG-2 file to 23.976 fps first.  Otherwise, in the Manual Trimmer you will just see a yellow border around the preview window when a duplicate frame is displayed, as a warning.  

Davis is on vacation until Feb.27.
  
Back to top
 
IP Logged
 
Angelica Vire
New Member
*
Offline


I Love YaBB 2!

Posts: 2
Joined: 24.02.2011
Re: HandySaw DS playback in Manual Trimmer
Reply #4 - 24.02.2011 at 01:52:53
Print Post  
Same result with Standard Renderer, Overlay Mixer, and System default video renderer.

« Last Edit: 02.03.2011 at 10:05:44 by Davis »  
Back to top
 
IP Logged
 
Davis
Forum Administrator
*****
Offline


Admin

Posts: 65
Location: Ukraine
Joined: 08.11.2005
Gender: Male
Re: HandySaw DS playback in Manual Trimmer
Reply #3 - 24.01.2011 at 09:42:10
Print Post  
OK.
Please, do:
1. Run HandySaw DS. Open Preferences/Logging. Turn on "Store debug info ...".  press OK
2. restart HandySaw DS, select source file and run Manual Trimmer.
3. Quit HandySaw.
4. Find "HandySaw Debug.log" in Documents\Davis Software\HandySaw DS and send me via e-mail.

Let's continue discussion via e-mail
  

Dmitry Sinitsyn,
Davis Software
Back to top
WWW  
IP Logged
 
Hyomil
New Member
*
Offline


I Love YaBB 2!

Posts: 3
Joined: 22.01.2011
Re: HandySaw DS playback in Manual Trimmer
Reply #2 - 24.01.2011 at 09:36:19
Print Post  
Same result with Standard Renderer, Overlay Mixer, and System default video renderer.  When I step, there are still 30 fps, some of which are repeats.  The Manual Trimmer position timecode goes from 1 to 29 before changing to the next second, and there's no skipping over any numbers in between, even when changing to Drop-Frame Timecode.

Tried various MPEG decompressors and demultiplexers, including the MPC standalone ones described in the manual and they produce various results such as not being to frame step at all, video being upside down, no video, or, on some frames, stepping backwards instead of forwards.  The one that seems best is Cyberlink for Video, ffdshow for Audio and Gabest for demultiplexer.  I'm using the latest K-Lite Codec Pack.

I can step through the video in Media Player Classic - Home Cinema with the same combination of decoders and demultiplexer (Cyberlink, ffdshow, Gabest) without the repeats, both with EVR and Overlay Mixer as a renderer.
  
Back to top
 
IP Logged
 
Davis
Forum Administrator
*****
Offline


Admin

Posts: 65
Location: Ukraine
Joined: 08.11.2005
Gender: Male
Re: HandySaw DS playback in Manual Trimmer
Reply #1 - 24.01.2011 at 08:11:03
Print Post  
Try to select Standard Renderer in the Renderer tab in Preferences.
I think MPEG decoder produces correct 23.976 stream but video renderer do telecine so you get NTSC video in result.
Standard Renderer must just display video as is.
  

Dmitry Sinitsyn,
Davis Software
Back to top
WWW  
IP Logged
 
Hyomil
New Member
*
Offline


I Love YaBB 2!

Posts: 3
Joined: 22.01.2011
HandySaw DS playback in Manual Trimmer
22.01.2011 at 04:40:24
Print Post  
I just bought a license and am impressed with Handysaw DS's extensive features  Cool, but I'm trying to use the Manual Trimmer on an .mpg file, which I created from an NTSC DVD (using the program VideoReDo's QuickStream Fix).  The film must have been stored on the DVD at 23.976 fps, but the playback is at 29.97 fps, which results, when frame-stepping through it, in frames often being displayed twice.  How can I prevent this?  There are no visible interlace lines, and the program Womble MPEG Video Wizard does not display any frames multiple times when I frame-step.

I've tried

1. using different MPEG Decompressors and Demultiplexers in Preferences, but they either won't play back at all or play back in the same way.  

2. patching the header using the program DVDPatcher to 23.976 fps (Entire file).
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic | Print